Service Issues with Hill Rom TotalCare Bed

Greetings. We’re starting to experience some interesting hydraulic conditions with our TotalCare beds, and I wanted to see if anyone here works on them like we do. If not, please ask whoever in your facility works on them.

We have had issues in the past with the seals on the “ice cube”
solenoids deteriorating. And it’s not the oldest beds, we have some P1900As in use and they don’t have this problem.

On one bed, it’s the head section, it slowly leaks down to where in a 20 to 30 minute span, it will go from 45 degrees to flat.

On two other beds, it’s the head side of the hi/low, where they slowly leaks down, One bed may take up to 24 hours to go all the way down, while the other may take 2 hours to go all the way down.

We’ve put in new seals in the hydraulic box, in one case at least twice, and the problem persists. The only other thing we can think of, and we’ve tried to jiggle it, is the CPR / Trend valve might be leaking.
We have not replaced any of them as of yet, and I’m wondering if anyone else out there has had this issue??

Thanks!

Ray Brown, CBET, KB0STN, BMET II
Freeman Health System, Joplin, MO
rabrown (at) freemanhealth (dot) com

Advertisements

Leave a comment

Filed under Question

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s